CRAN Package Check Results for Package RRphylo

Last updated on 2022-01-26 06:50:27 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 2.6.0 26.25 378.84 405.09 NOTE
r-devel-linux-x86_64-debian-gcc 2.6.0 23.53 277.11 300.64 NOTE
r-devel-linux-x86_64-fedora-clang 2.6.0 498.31 NOTE
r-devel-linux-x86_64-fedora-gcc 2.6.0 463.19 NOTE
r-devel-windows-x86_64-new-UL 2.6.0 88.00 525.00 613.00 NOTE
r-devel-windows-x86_64-new-TK 2.6.0 WARN
r-patched-linux-x86_64 2.6.0 27.22 373.33 400.55 NOTE
r-release-linux-x86_64 2.6.0 25.49 375.31 400.80 NOTE
r-release-macos-arm64 2.5.9 NOTE
r-release-macos-x86_64 2.6.0 NOTE
r-release-windows-ix86+x86_64 2.6.0 50.00 552.00 602.00 ERROR
r-oldrel-macos-x86_64 2.6.0 NOTE
r-oldrel-windows-ix86+x86_64 2.6.0 50.00 554.00 604.00 ERROR

Check Details

Version: 2.6.0
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: 'webshot2'
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64-new-UL, r-patched-linux-x86_64, r-release-linux-x86_64, r-release-macos-x86_64, r-release-windows-ix86+x86_64, r-oldrel-macos-x86_64, r-oldrel-windows-ix86+x86_64

Version: 2.6.0
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking: 'car', 'webshot2'
Flavor: r-devel-windows-x86_64-new-TK

Version: 2.6.0
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building 'RRphylo.Rmd' using rmarkdown
    Loading required package: ape
    Loading required package: kableExtra
    Loading required package: phytools
    Loading required package: maps
    
    Attaching package: 'phytools'
    
    The following object is masked from 'package:RRphylo':
    
     node.paths
    
    Loading required package: geiger
    --- finished re-building 'RRphylo.Rmd'
    
    --- re-building 'Tree-Manipulation.Rmd' using rmarkdown
    --- finished re-building 'Tree-Manipulation.Rmd'
    
    --- re-building 'overfitRR.Rmd' using rmarkdown
    --- finished re-building 'overfitRR.Rmd'
    
    --- re-building 'search.conv.Rmd' using rmarkdown
    Loading required package: vegan
    Loading required package: permute
    Loading required package: lattice
    This is vegan 2.5-7
    
    Attaching package: 'vegan'
    
    The following object is masked from 'package:phytools':
    
     scores
    
    Loading required package: cluster
    
    Attaching package: 'cluster'
    
    The following object is masked from 'package:maps':
    
     votes.repub
    
    Loading required package: plotrix
    
    Attaching package: 'plotrix'
    
    The following object is masked from 'package:rgl':
    
     mtext3d
    
    The following object is masked from 'package:geiger':
    
     rescale
    
    Loading required package: geomorph
    Loading required package: RRPP
    Loading required package: Matrix
    Loading required package: pdftools
    Using poppler version 21.04.0
    --- finished re-building 'search.conv.Rmd'
    
    --- re-building 'search.shift.Rmd' using rmarkdown
    Loading required package: scales
    
    Attaching package: 'scales'
    
    The following object is masked from 'package:plotrix':
    
     rescale
    
    The following object is masked from 'package:geiger':
    
     rescale
    
    --- finished re-building 'search.shift.Rmd'
    
    --- re-building 'search.trend.Rmd' using rmarkdown
    Loading required package: ddpcr
    
    Attaching package: 'ddpcr'
    
    The following object is masked from 'package:stats':
    
     step
    
    Quitting from lines 43-165 (search.trend.Rmd)
    Error: processing vignette 'search.trend.Rmd' failed with diagnostics:
    Package "car" needed for this function to work. Please install it.
    --- failed re-building 'search.trend.Rmd'
    
    --- re-building 'swapONE.Rmd' using rmarkdown
    --- finished re-building 'swapONE.Rmd'
    
    SUMMARY: processing the following file failed:
     'search.trend.Rmd'
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-devel-windows-x86_64-new-TK

Version: 2.5.9
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘webshot2’
Flavor: r-release-macos-arm64

Version: 2.6.0
Check: PDF version of manual
Result: WARN
    LaTeX errors when creating PDF version.
    This typically indicates Rd problems.
    LaTeX errors found:
    ! Package inputenc Error: Unicode char â<c2><80><c2><90> (U+2010)
    (inputenc) not set up for use with LaTeX.
    
    See the inputenc package documentation for explanation.
    Type H <return> for immediate help.
    ! Package inputenc Error: Unicode char â<c2><80><c2><90> (U+2010)
    (inputenc) not set up for use with LaTeX.
    
    See the inputenc package documentation for explanation.
    Type H <return> for immediate help.
Flavors: r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64

Version: 2.6.0
Check: PDF version of manual without hyperrefs or index
Result: ERROR
Flavors: r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64